[52N Geoprocessingservices] Error on sextante process idw

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[52N Geoprocessingservices] Error on sextante process idw

Daniel Moraru

Hi List,
I want to give the new wps an second try (rc5). I made a fresh checkout and proceed as described in the tutorial. The Sextante processes are enabled and the ip address and port is set. I also checked the parsers, they are all on.

After this I replaced the wps rc4 with the new one and let my application work. I got an error on a idw request in the new wps which works fine in the old wps (rc4).

My second test with a kriging request fails too.


Regards,

Daniel



The error I get in the wps response:

<ns:ExceptionReport>
<ns:Exception exceptionCode="NoApplicableCode">
<ns:ExceptionText>
Error. No applicable parser found for null,application/x-zipped-shp,UTF-8
</ns:ExceptionText>
</ns:Exception>
<ns:Exception exceptionCode="JAVA_StackTrace">
<ns:ExceptionText>
org.n52.wps.server.request.InputHandler.handleComplexValueReference:319
org.n52.wps.server.request.InputHandler.<init>:109
org.n52.wps.server.request.ExecuteRequest.call:518
org.n52.wps.server.request.ExecuteRequest.call:77
java.util.concurrent.FutureTask$Sync.innerRun:303
java.util.concurrent.FutureTask.run:138
java.util.concurrent.ThreadPoolExecutor$Worker.runTask:886
java.util.concurrent.ThreadPoolExecutor$Worker.run:908
java.lang.Thread.run:619
</ns:ExceptionText>
</ns:Exception>
<ns:Exception exceptionCode="JAVA_RootCause"/>
</ns:ExceptionReport>


the console output:

161203 [http-80-2] INFO org.n52.wps.server.request.Request  - Handled Request successfully for: idw
1500453 [pool-1-thread-2] WARN org.n52.wps.server.request.InputHandler  - No applicable parser found. Trying simpleGMLParser
1500453 [pool-1-thread-2] ERROR org.n52.wps.server.handler.RequestExecutor  - Task execution failed: org.n52.wps.server.ExceptionReport: Error. No applicable parser found for null,application/x-zipped-shp,UTF-8


My testrequest for idw:

<wps:Execute service="WPS"
version="1.0.0"
xmlns:wps="http://www.opengis.net/wps/1.0.0"
xmlns:ows="http://www.opengis.net/ows/1.1"
xmlns:xlink="http://www.w3.org/1999/xlink"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.opengis.net/wps/1.0.0/wpsExecute_request.xsd">
<ows:Identifier>idw</ows:Identifier>
<wps:DataInputs>
    <wps:Input>
        <ows:Identifier>LAYER</ows:Identifier>
        <ows:Title>Die zu bearbeitenden Punkte</ows:Title>
        <wps:Reference mimeType="application/x-zipped-shp" xlink:href="http://localhost:80/data/test.zip"/>
    </wps:Input>
        <wps:Input>
            <ows:Identifier>FIELD</ows:Identifier>
            <wps:Data> 
                <wps:LiteralData dataType="xs:int">0</wps:LiteralData>
            </wps:Data>
        </wps:Input>
        <wps:Input>
            <ows:Identifier>DIST</ows:Identifier>
            <wps:Data>
                <wps:LiteralData dataType="xs:double">16000</wps:LiteralData>
            </wps:Data>
        </wps:Input>
        <wps:Input>
            <ows:Identifier>POWER</ows:Identifier>
            <wps:Data>
                <wps:LiteralData dataType="xs:double">2.0</wps:LiteralData>
            </wps:Data>
        </wps:Input>
        <wps:Input>
            <ows:Identifier>GRID_EXTENT_X_MIN</ows:Identifier>
            <wps:Data>
                <wps:LiteralData dataType="xs:double">2557153.02</wps:LiteralData>
            </wps:Data>
        </wps:Input>
        <wps:Input>
            <ows:Identifier>GRID_EXTENT_X_MAX</ows:Identifier>
            <wps:Data>
                <wps:LiteralData dataType="xs:double">2616560.87</wps:LiteralData>
            </wps:Data>
        </wps:Input>
        <wps:Input>
            <ows:Identifier>GRID_EXTENT_Y_MIN</ows:Identifier>
            <wps:Data>
                <wps:LiteralData dataType="xs:double">5647888.89</wps:LiteralData>
            </wps:Data>
        </wps:Input>
        <wps:Input>
            <ows:Identifier>GRID_EXTENT_Y_MAX</ows:Identifier>
            <wps:Data>
                <wps:LiteralData dataType="xs:double">5692600.02</wps:LiteralData>
            </wps:Data>
        </wps:Input>
        <wps:Input>
            <ows:Identifier>GRID_EXTENT_CELLSIZE</ows:Identifier>
            <wps:Data>
                <wps:LiteralData dataType="xs:double">100</wps:LiteralData>
            </wps:Data>
        </wps:Input>
    </wps:DataInputs>
    <wps:ResponseForm>
        <wps:ResponseDocument>
            <wps:Output asReference="true">
                <ows:Identifier>RESULT</ows:Identifier>
            </wps:Output>
        </wps:ResponseDocument>
    </wps:ResponseForm>
</wps:Execute>







_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://www2.52north.org/mailman/listinfo/geoprocessingservices

test.zip (2K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [52N Geoprocessingservices] Error on sextante process idw

Bastian Schäffer
Hi Daniel,

I just tested it. Works fine on my machine.

Did you checkout the latest version or did you update from RC4.

Could you do a:
http://localhost:8080/wps/WebProcessingService?Request=DescribeProcess&Service=WPS&identifier=idw

and make sure that

application/x-zipped-shp

is supported.

From the error message you send, it look like the parser is not enabled
or (and that changed in RC5) the wps_config.xml is not up to date. In
RC5 the supported mimetypes have to specified in the wps_config.xml and
not anymore hard coded in the parsers itself.

Regards,
Bastian

Am 21.08.2010 16:14, schrieb Daniel Moraru:

> Hi List,
> I want to give the new wps an second try (rc5). I made a fresh checkout
> and proceed as described in the tutorial. The Sextante processes are
> enabled and the ip address and port is set. I also checked the parsers,
> they are all on.
>
> After this I replaced the wps rc4 with the new one and let my
> application work. I got an error on a idw request in the new wps which
> works fine in the old wps (rc4).
>
> My second test with a kriging request fails too.
>
>
> Regards,
>
> Daniel
>
>
>
> The error I get in the wps response:
>
> <ns:ExceptionReport>
> <ns:Exception exceptionCode="NoApplicableCode">
> <ns:ExceptionText>
> Error. No applicable parser found for null,application/x-zipped-shp,UTF-8
> </ns:ExceptionText>
> </ns:Exception>
> <ns:Exception exceptionCode="JAVA_StackTrace">
> <ns:ExceptionText>
> org.n52.wps.server.request.InputHandler.handleComplexValueReference:319
> org.n52.wps.server.request.InputHandler.<init>:109
> org.n52.wps.server.request.ExecuteRequest.call:518
> org.n52.wps.server.request.ExecuteRequest.call:77
> java.util.concurrent.FutureTask$Sync.innerRun:303
> java.util.concurrent.FutureTask.run:138
> java.util.concurrent.ThreadPoolExecutor$Worker.runTask:886
> java.util.concurrent.ThreadPoolExecutor$Worker.run:908
> java.lang.Thread.run:619
> </ns:ExceptionText>
> </ns:Exception>
> <ns:Exception exceptionCode="JAVA_RootCause"/>
> </ns:ExceptionReport>
>
>
> the console output:
>
> 161203 [http-80-2] INFO org.n52.wps.server.request.Request  - Handled
> Request successfully for: idw
> 1500453 [pool-1-thread-2] WARN org.n52.wps.server.request.InputHandler
> - No applicable parser found. Trying simpleGMLParser
> 1500453 [pool-1-thread-2] ERROR
> org.n52.wps.server.handler.RequestExecutor  - Task execution failed:
> org.n52.wps.server.ExceptionReport: Error. No applicable parser found
> for null,application/x-zipped-shp,UTF-8
>
>
> My testrequest for idw:
>
> <wps:Execute service="WPS"
> version="1.0.0"
> xmlns:wps="http://www.opengis.net/wps/1.0.0"
> xmlns:ows="http://www.opengis.net/ows/1.1"
> xmlns:xlink="http://www.w3.org/1999/xlink"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xsi:schemaLocation="http://www.opengis.net/wps/1.0.0/wpsExecute_request.xsd">
>
> <ows:Identifier>idw</ows:Identifier>
> <wps:DataInputs>
>     <wps:Input>
>         <ows:Identifier>LAYER</ows:Identifier>
>         <ows:Title>Die zu bearbeitenden Punkte</ows:Title>
>         <wps:Reference mimeType="application/x-zipped-shp"
> xlink:href="http://localhost:80/data/test.zip"/>
>     </wps:Input>
>         <wps:Input>
>             <ows:Identifier>FIELD</ows:Identifier>
>             <wps:Data>
>                 <wps:LiteralData dataType="xs:int">0</wps:LiteralData>
>             </wps:Data>
>         </wps:Input>
>         <wps:Input>
>             <ows:Identifier>DIST</ows:Identifier>
>             <wps:Data>
>                 <wps:LiteralData
> dataType="xs:double">16000</wps:LiteralData>
>             </wps:Data>
>         </wps:Input>
>         <wps:Input>
>             <ows:Identifier>POWER</ows:Identifier>
>             <wps:Data>
>                 <wps:LiteralData dataType="xs:double">2.0</wps:LiteralData>
>             </wps:Data>
>         </wps:Input>
>         <wps:Input>
>             <ows:Identifier>GRID_EXTENT_X_MIN</ows:Identifier>
>             <wps:Data>
>                 <wps:LiteralData
> dataType="xs:double">2557153.02</wps:LiteralData>
>             </wps:Data>
>         </wps:Input>
>         <wps:Input>
>             <ows:Identifier>GRID_EXTENT_X_MAX</ows:Identifier>
>             <wps:Data>
>                 <wps:LiteralData
> dataType="xs:double">2616560.87</wps:LiteralData>
>             </wps:Data>
>         </wps:Input>
>         <wps:Input>
>             <ows:Identifier>GRID_EXTENT_Y_MIN</ows:Identifier>
>             <wps:Data>
>                 <wps:LiteralData
> dataType="xs:double">5647888.89</wps:LiteralData>
>             </wps:Data>
>         </wps:Input>
>         <wps:Input>
>             <ows:Identifier>GRID_EXTENT_Y_MAX</ows:Identifier>
>             <wps:Data>
>                 <wps:LiteralData
> dataType="xs:double">5692600.02</wps:LiteralData>
>             </wps:Data>
>         </wps:Input>
>         <wps:Input>
>             <ows:Identifier>GRID_EXTENT_CELLSIZE</ows:Identifier>
>             <wps:Data>
>                 <wps:LiteralData dataType="xs:double">100</wps:LiteralData>
>             </wps:Data>
>         </wps:Input>
>     </wps:DataInputs>
>     <wps:ResponseForm>
>         <wps:ResponseDocument>
>             <wps:Output asReference="true">
>                 <ows:Identifier>RESULT</ows:Identifier>
>             </wps:Output>
>         </wps:ResponseDocument>
>     </wps:ResponseForm>
> </wps:Execute>
>
>
>
>
>
>
>
>
> _______________________________________________
> Geoprocessingservices mailing list
> [hidden email]
> http://www2.52north.org/mailman/listinfo/geoprocessingservices


--
Bastian Schäffer
Institute for Geoinformatics (IfGI), University of Muenster, Germany
Weseler Str. 253, 48151 Muenster
Fon: +49 (0)251 - 83-30046   Fax: +49 (0)251 - 83-39763
email: [hidden email]
IfGI-site: http://ifgi.uni-muenster.de



_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://www2.52north.org/mailman/listinfo/geoprocessingservices
Reply | Threaded
Open this post in threaded view
|

Re: [52N Geoprocessingservices] Error on sextante process idw‏

Daniel Moraru



From: [hidden email]
To: [hidden email]
Subject: RE: [52N Geoprocessingservices] Error on sextante process idw
Date: Sat, 21 Aug 2010 22:36:47 +0200

Hi Bastian,

I'm working with a new rc5 version of the wps, no update from the rc4.
The process description is attached. It looks strange to me and I don't no why it doesn't work here.
I know that I'm not the only one with this problem, I chatted with some other guys who have the same problems.

Regards,
Daniel



> Date: Sat, 21 Aug 2010 18:31:28 +0200
> From: [hidden email]
> To: [hidden email]; [hidden email]
> Subject: Re: [52N Geoprocessingservices] Error on sextante process idw
>
> Hi Daniel,
>
> I just tested it. Works fine on my machine.
>
> Did you checkout the latest version or did you update from RC4.
>
> Could you do a:
> http://localhost:8080/wps/WebProcessingService?Request=DescribeProcess&Service=WPS&identifier=idw
>
> and make sure that
>
> application/x-zipped-shp
>
> is supported.
>
> From the error message you send, it look like the parser is not enabled
> or (and that changed in RC5) the wps_config.xml is not up to date. In
> RC5 the supported mimetypes have to specified in the wps_config.xml and
> not anymore hard coded in the parsers itself.
>
> Regards,
> Bastian
>
> Am 21.08.2010 16:14, schrieb Daniel Moraru:
> > Hi List,
> > I want to give the new wps an second try (rc5). I made a fresh checkout
> > and proceed as described in the tutorial. The Sextante processes are
> > enabled and the ip address and port is set. I also checked the parsers,
> > they are all on.
> >
> > After this I replaced the wps rc4 with the new one and let my
> > application work. I got an error on a idw request in the new wps which
> > works fine in the old wps (rc4).
> >
> > My second test with a kriging request fails too.
> >
> >
> > Regards,
> >
> > Daniel
> >
> >
> >
> > The error I get in the wps response:
> >
> > <ns:ExceptionReport>
> > <ns:Exception exceptionCode="NoApplicableCode">
> > <ns:ExceptionText>
> > Error. No applicable parser found for null,application/x-zipped-shp,UTF-8
> > </ns:ExceptionText>
> > </ns:Exception>
> > <ns:Exception exceptionCode="JAVA_StackTrace">
> > <ns:ExceptionText>
> > org.n52.wps.server.request.InputHandler.handleComplexValueReference:319
> > org.n52.wps.server.request.InputHandler.<init>:109
> > org.n52.wps.server.request.ExecuteRequest.call:518
> > org.n52.wps.server.request.ExecuteRequest.call:77
> > java.util.concurrent.FutureTask$Sync.innerRun:303
> > java.util.concurrent.FutureTask.run:138
> > java.util.concurrent.ThreadPoolExecutor$Worker.runTask:886
> > java.util.concurrent.ThreadPoolExecutor$Worker.run:908
> > java.lang.Thread.run:619
> > </ns:ExceptionText>
> > </ns:Exception>
> > <ns:Exception exceptionCode="JAVA_RootCause"/>
> > </ns:ExceptionReport>
> >
> >
> > the console output:
> >
> > 161203 [http-80-2] INFO org.n52.wps.server.request.Request - Handled
> > Request successfully for: idw
> > 1500453 [pool-1-thread-2] WARN org.n52.wps.server.request.InputHandler
> > - No applicable parser found. Trying simpleGMLParser
> > 1500453 [pool-1-thread-2] ERROR
> > org.n52.wps.server.handler.RequestExecutor - Task execution failed:
> > org.n52.wps.server.ExceptionReport: Error. No applicable parser found
> > for null,application/x-zipped-shp,UTF-8
> >
> >
> > My testrequest for idw:
> >
> > <wps:Execute service="WPS"
> > version="1.0.0"
> > xmlns:wps="http://www.opengis.net/wps/1.0.0"
> > xmlns:ows="http://www.opengis.net/ows/1.1"
> > xmlns:xlink="http://www.w3.org/1999/xlink"
> > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> > xsi:schemaLocation="http://www.opengis.net/wps/1.0.0/wpsExecute_request.xsd">
> >
> > <ows:Identifier>idw</ows:Identifier>
> > <wps:DataInputs>
> > <wps:Input>
> > <ows:Identifier>LAYER</ows:Identifier>
> > <ows:Title>Die zu bearbeitenden Punkte</ows:Title>
> > <wps:Reference mimeType="application/x-zipped-shp"
> > xlink:href="http://localhost:80/data/test.zip"/>
> > </wps:Input>
> > <wps:Input>
> > <ows:Identifier>FIELD</ows:Identifier>
> > <wps:Data>
> > <wps:LiteralData dataType="xs:int">0</wps:LiteralData>
> > </wps:Data>
> > </wps:Input>
> > <wps:Input>
> > <ows:Identifier>DIST</ows:Identifier>
> > <wps:Data>
> > <wps:LiteralData
> > dataType="xs:double">16000</wps:LiteralData>
> > </wps:Data>
> > </wps:Input>
> > <wps:Input>
> > <ows:Identifier>POWER</ows:Identifier>
> > <wps:Data>
> > <wps:LiteralData dataType="xs:double">2.0</wps:LiteralData>
> > </wps:Data>
> > </wps:Input>
> > <wps:Input>
> > <ows:Identifier>GRID_EXTENT_X_MIN</ows:Identifier>
> > <wps:Data>
> > <wps:LiteralData
> > dataType="xs:double">2557153.02</wps:LiteralData>
> > </wps:Data>
> > </wps:Input>
> > <wps:Input>
> > <ows:Identifier>GRID_EXTENT_X_MAX</ows:Identifier>
> > <wps:Data>
> > <wps:LiteralData
> > dataType="xs:double">2616560.87</wps:LiteralData>
> > </wps:Data>
> > </wps:Input>
> > <wps:Input>
> > <ows:Identifier>GRID_EXTENT_Y_MIN</ows:Identifier>
> > <wps:Data>
> > <wps:LiteralData
> > dataType="xs:double">5647888.89</wps:LiteralData>
> > </wps:Data>
> > </wps:Input>
> > <wps:Input>
> > <ows:Identifier>GRID_EXTENT_Y_MAX</ows:Identifier>
> > <wps:Data>
> > <wps:LiteralData
> > dataType="xs:double">5692600.02</wps:LiteralData>
> > </wps:Data>
> > </wps:Input>
> > <wps:Input>
> > <ows:Identifier>GRID_EXTENT_CELLSIZE</ows:Identifier>
> > <wps:Data>
> > <wps:LiteralData dataType="xs:double">100</wps:LiteralData>
> > </wps:Data>
> > </wps:Input>
> > </wps:DataInputs>
> > <wps:ResponseForm>
> > <wps:ResponseDocument>
> > <wps:Output asReference="true">
> > <ows:Identifier>RESULT</ows:Identifier>
> > </wps:Output>
> > </wps:ResponseDocument>
> > </wps:ResponseForm>
> > </wps:Execute>
> >
> >
> >
> >
> >
> >
> >
> >
> > _______________________________________________
> > Geoprocessingservices mailing list
> > [hidden email]
> > http://www2.52north.org/mailman/listinfo/geoprocessingservices
>
>
> --
> Bastian Schäffer
> Institute for Geoinformatics (IfGI), University of Muenster, Germany
> Weseler Str. 253, 48151 Muenster
> Fon: +49 (0)251 - 83-30046 Fax: +49 (0)251 - 83-39763
> email: [hidden email]
> IfGI-site: http://ifgi.uni-muenster.de
>
>
>

_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://www2.52north.org/mailman/listinfo/geoprocessingservices

idw.xml (9K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [52N Geoprocessingservices] Error on sextante process idw‏

Bastian Schäffer
Hi Daniel,

I tested it on another clean machine. Works still fine.

By looking at your ProcessesDescription I noted that the schema and
mimetype for the inputs are URL encoded which should not be the case.

Could you check in your wps_config.xml, if the parsers have url encoded
values for supported mimetypes?

The wps_config.xml in the repository does not have url encoded mimetypes.
My suspicion is therefore that the WPSAdmin page was used to alter the
config. The WPSAdmin page did some URLencoding which was not reverted in
the business logic.
Can you confirm?

In that case we have a bug in the WPSAdmin businesslogic.

Regards,
Bastian

Am 21.08.2010 22:38, schrieb Daniel Moraru:

>
>
> ------------------------------------------------------------------------
> From: [hidden email]
> To: [hidden email]
> Subject: RE: [52N Geoprocessingservices] Error on sextante process idw
> Date: Sat, 21 Aug 2010 22:36:47 +0200
>
> Hi Bastian,
>
> I'm working with a new rc5 version of the wps, no update from the rc4.
> The process description is attached. It looks strange to me and I don't
> no why it doesn't work here.
> I know that I'm not the only one with this problem, I chatted with some
> other guys who have the same problems.
>
> Regards,
> Daniel
>
>
>
>> Date: Sat, 21 Aug 2010 18:31:28 +0200
>> From: [hidden email]
>> To: [hidden email]; [hidden email]
>> Subject: Re: [52N Geoprocessingservices] Error on sextante process idw
>>
>> Hi Daniel,
>>
>> I just tested it. Works fine on my machine.
>>
>> Did you checkout the latest version or did you update from RC4.
>>
>> Could you do a:
>>
> http://localhost:8080/wps/WebProcessingService?Request=DescribeProcess&Service=WPS&identifier=idw
>>
>> and make sure that
>>
>> application/x-zipped-shp
>>
>> is supported.
>>
>> From the error message you send, it look like the parser is not enabled
>> or (and that changed in RC5) the wps_config.xml is not up to date. In
>> RC5 the supported mimetypes have to specified in the wps_config.xml and
>> not anymore hard coded in the parsers itself.
>>
>> Regards,
>> Bastian
>>
>> Am 21.08.2010 16:14, schrieb Daniel Moraru:
>> > Hi List,
>> > I want to give the new wps an second try (rc5). I made a fresh checkout
>> > and proceed as described in the tutorial. The Sextante processes are
>> > enabled and the ip address and port is set. I also checked the parsers,
>> > they are all on.
>> >
>> > After this I replaced the wps rc4 with the new one and let my
>> > application work. I got an error on a idw request in the new wps which
>> > works fine in the old wps (rc4).
>> >
>> > My second test with a kriging request fails too.
>> >
>> >
>> > Regards,
>> >
>> > Daniel
>> >
>> >
>> >
>> > The error I get in the wps response:
>> >
>> > <ns:ExceptionReport>
>> > <ns:Exception exceptionCode="NoApplicableCode">
>> > <ns:ExceptionText>
>> > Error. No applicable parser found for
> null,application/x-zipped-shp,UTF-8
>> > </ns:ExceptionText>
>> > </ns:Exception>
>> > <ns:Exception exceptionCode="JAVA_StackTrace">
>> > <ns:ExceptionText>
>> > org.n52.wps.server.request.InputHandler.handleComplexValueReference:319
>> > org.n52.wps.server.request.InputHandler.<init>:109
>> > org.n52.wps.server.request.ExecuteRequest.call:518
>> > org.n52.wps.server.request.ExecuteRequest.call:77
>> > java.util.concurrent.FutureTask$Sync.innerRun:303
>> > java.util.concurrent.FutureTask.run:138
>> > java.util.concurrent.ThreadPoolExecutor$Worker.runTask:886
>> > java.util.concurrent.ThreadPoolExecutor$Worker.run:908
>> > java.lang.Thread.run:619
>> > </ns:ExceptionText>
>> > </ns:Exception>
>> > <ns:Exception exceptionCode="JAVA_RootCause"/>
>> > </ns:ExceptionReport>
>> >
>> >
>> > the console output:
>> >
>> > 161203 [http-80-2] INFO org.n52.wps.server.request.Request - Handled
>> > Request successfully for: idw
>> > 1500453 [pool-1-thread-2] WARN org.n52.wps.server.request.InputHandler
>> > - No applicable parser found. Trying simpleGMLParser
>> > 1500453 [pool-1-thread-2] ERROR
>> > org.n52.wps.server.handler.RequestExecutor - Task execution failed:
>> > org.n52.wps.server.ExceptionReport: Error. No applicable parser found
>> > for null,application/x-zipped-shp,UTF-8
>> >
>> >
>> > My testrequest for idw:
>> >
>> > <wps:Execute service="WPS"
>> > version="1.0.0"
>> > xmlns:wps="http://www.opengis.net/wps/1.0.0"
>> > xmlns:ows="http://www.opengis.net/ows/1.1"
>> > xmlns:xlink="http://www.w3.org/1999/xlink"
>> > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>> >
> xsi:schemaLocation="http://www.opengis.net/wps/1.0.0/wpsExecute_request.xsd">
>> >
>> > <ows:Identifier>idw</ows:Identifier>
>> > <wps:DataInputs>
>> > <wps:Input>
>> > <ows:Identifier>LAYER</ows:Identifier>
>> > <ows:Title>Die zu bearbeitenden Punkte</ows:Title>
>> > <wps:Reference mimeType="application/x-zipped-shp"
>> > xlink:href="http://localhost:80/data/test.zip"/>
>> > </wps:Input>
>> > <wps:Input>
>> > <ows:Identifier>FIELD</ows:Identifier>
>> > <wps:Data>
>> > <wps:LiteralData dataType="xs:int">0</wps:LiteralData>
>> > </wps:Data>
>> > </wps:Input>
>> > <wps:Input>
>> > <ows:Identifier>DIST</ows:Identifier>
>> > <wps:Data>
>> > <wps:LiteralData
>> > dataType="xs:double">16000</wps:LiteralData>
>> > </wps:Data>
>> > </wps:Input>
>> > <wps:Input>
>> > <ows:Identifier>POWER</ows:Identifier>
>> > <wps:Data>
>> > <wps:LiteralData dataType="xs:double">2.0</wps:LiteralData>
>> > </wps:Data>
>> > </wps:Input>
>> > <wps:Input>
>> > <ows:Identifier>GRID_EXTENT_X_MIN</ows:Identifier>
>> > <wps:Data>
>> > <wps:LiteralData
>> > dataType="xs:double">2557153.02</wps:LiteralData>
>> > </wps:Data>
>> > </wps:Input>
>> > <wps:Input>
>> > <ows:Identifier>GRID_EXTENT_X_MAX</ows:Identifier>
>> > <wps:Data>
>> > <wps:LiteralData
>> > dataType="xs:double">2616560.87</wps:LiteralData>
>> > </wps:Data>
>> > </wps:Input>
>> > <wps:Input>
>> > <ows:Identifier>GRID_EXTENT_Y_MIN</ows:Identifier>
>> > <wps:Data>
>> > <wps:LiteralData
>> > dataType="xs:double">5647888.89</wps:LiteralData>
>> > </wps:Data>
>> > </wps:Input>
>> > <wps:Input>
>> > <ows:Identifier>GRID_EXTENT_Y_MAX</ows:Identifier>
>> > <wps:Data>
>> > <wps:LiteralData
>> > dataType="xs:double">5692600.02</wps:LiteralData>
>> > </wps:Data>
>> > </wps:Input>
>> > <wps:Input>
>> > <ows:Identifier>GRID_EXTENT_CELLSIZE</ows:Identifier>
>> > <wps:Data>
>> > <wps:LiteralData dataType="xs:double">100</wps:LiteralData>
>> > </wps:Data>
>> > </wps:Input>
>> > </wps:DataInputs>
>> > <wps:ResponseForm>
>> > <wps:ResponseDocument>
>> > <wps:Output asReference="true">
>> > <ows:Identifier>RESULT</ows:Identifier>
>> > </wps:Output>
>> > </wps:ResponseDocument>
>> > </wps:ResponseForm>
>> > </wps:Execute>
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> >
>> > _______________________________________________
>> > Geoprocessingservices mailing list
>> > [hidden email]
>> > http://www2.52north.org/mailman/listinfo/geoprocessingservices
>>
>>
>> --
>> Bastian Schäffer
>> Institute for Geoinformatics (IfGI), University of Muenster, Germany
>> Weseler Str. 253, 48151 Muenster
>> Fon: +49 (0)251 - 83-30046 Fax: +49 (0)251 - 83-39763
>> email: [hidden email]
>> IfGI-site: http://ifgi.uni-muenster.de
>>
>>
>>
>
>
>
> _______________________________________________
> Geoprocessingservices mailing list
> [hidden email]
> http://www2.52north.org/mailman/listinfo/geoprocessingservices


--
Bastian Schäffer
Institute for Geoinformatics (IfGI), University of Muenster, Germany
Weseler Str. 253, 48151 Muenster
Fon: +49 (0)251 - 83-30046   Fax: +49 (0)251 - 83-39763
email: [hidden email]
IfGI-site: http://ifgi.uni-muenster.de



_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://www2.52north.org/mailman/listinfo/geoprocessingservices
Reply | Threaded
Open this post in threaded view
|

Re: [52N Geoprocessingservices] Error on sextante process idw‏

Bastian Schäffer
Hi Daniel,

I commited a fix. My tests show that the problem is solved.
If you find some time, please try again.

Thanks again for reporting this bug.

Regards,
Bastian Schäffer

Am 22.08.2010 21:24, schrieb Daniel Moraru:

> Hi Bastian,
> thanks for the prompt help. It works for me now.
>
> You are right, there is a problem in the WPSAdmin. You only have to
> enter the console and click on save, it changes the wpsconfig file into
> URLencoding. Before that the wps works fine and afterwards it didn't
> work since you fix the wpsconfig file manually.
>
> Thanks
> Daniel
>
>> Date: Sun, 22 Aug 2010 13:29:45 +0200
>> From: [hidden email]
>> To: [hidden email]; [hidden email]
>> Subject: Re: [52N Geoprocessingservices] Error on sextante process idw‏
>>
>> Hi Daniel,
>>
>> I tested it on another clean machine. Works still fine.
>>
>> By looking at your ProcessesDescription I noted that the schema and
>> mimetype for the inputs are URL encoded which should not be the case.
>>
>> Could you check in your wps_config.xml, if the parsers have url encoded
>> values for supported mimetypes?
>>
>> The wps_config.xml in the repository does not have url encoded mimetypes.
>> My suspicion is therefore that the WPSAdmin page was used to alter the
>> config. The WPSAdmin page did some URLencoding which was not reverted in
>> the business logic.
>> Can you confirm?
>>
>> In that case we have a bug in the WPSAdmin businesslogic.
>>
>> Regards,
>> Bastian
>>
>> Am 21.08.2010 22:38, schrieb Daniel Moraru:
>> >
>> >
>> > ------------------------------------------------------------------------
>> > From: [hidden email]
>> > To: [hidden email]
>> > Subject: RE: [52N Geoprocessingservices] Error on sextante process idw
>> > Date: Sat, 21 Aug 2010 22:36:47 +0200
>> >
>> > Hi Bastian,
>> >
>> > I'm working with a new rc5 version of the wps, no update from the rc4.
>> > The process description is attached. It looks strange to me and I don't
>> > no why it doesn't work here.
>> > I know that I'm not the only one with this problem, I chatted with some
>> > other guys who have the same problems.
>> >
>> > Regards,
>> > Daniel
>> >
>> >
>> >
>> >> Date: Sat, 21 Aug 2010 18:31:28 +0200
>> >> From: [hidden email]
>> >> To: [hidden email]; [hidden email]
>> >> Subject: Re: [52N Geoprocessingservices] Error on sextante process idw
>> >>
>> >> Hi Daniel,
>> >>
>> >> I just tested it. Works fine on my machine.
>> >>
>> >> Did you checkout the latest version or did you update from RC4.
>> >>
>> >> Could you do a:
>> >>
>> >
> http://localhost:8080/wps/WebProcessingService?Request=DescribeProcess&Service=WPS&identifier=idw
>> >>
>> >> and make sure that
>> >>
>> >> application/x-zipped-shp
>> >>
>> >> is supported.
>> >>
>> >> From the error message you send, it look like the parser is not enabled
>> >> or (and that changed in RC5) the wps_config.xml is not up to date. In
>> >> RC5 the supported mimetypes have to specified in the wps_config.xml and
>> >> not anymore hard coded in the parsers itself.
>> >>
>> >> Regards,
>> >> Bastian
>> >>
>> >> Am 21.08.2010 16:14, schrieb Daniel Moraru:
>> >> > Hi List,
>> >> > I want to give the new wps an second try (rc5). I made a fresh
> checkout
>> >> > and proceed as described in the tutorial. The Sextante processes are
>> >> > enabled and the ip address and port is set. I also checked the
> parsers,
>> >> > they are all on.
>> >> >
>> >> > After this I replaced the wps rc4 with the new one and let my
>> >> > application work. I got an error on a idw request in the new wps
> which
>> >> > works fine in the old wps (rc4).
>> >> >
>> >> > My second test with a kriging request fails too.
>> >> >
>> >> >
>> >> > Regards,
>> >> >
>> >> > Daniel
>> >> >
>> >> >
>> >> >
>> >> > The error I get in the wps response:
>> >> >
>> >> > <ns:ExceptionReport>
>> >> > <ns:Exception exceptionCode="NoApplicableCode">
>> >> > <ns:ExceptionText>
>> >> > Error. No applicable parser found for
>> > null,application/x-zipped-shp,UTF-8
>> >> > </ns:ExceptionText>
>> >> > </ns:Exception>
>> >> > <ns:Exception exceptionCode="JAVA_StackTrace">
>> >> > <ns:ExceptionText>
>> >> >
> org.n52.wps.server.request.InputHandler.handleComplexValueReference:319
>> >> > org.n52.wps.server.request.InputHandler.<init>:109
>> >> > org.n52.wps.server.request.ExecuteRequest.call:518
>> >> > org.n52.wps.server.request.ExecuteRequest.call:77
>> >> > java.util.concurrent.FutureTask$Sync.innerRun:303
>> >> > java.util.concurrent.FutureTask.run:138
>> >> > java.util.concurrent.ThreadPoolExecutor$Worker.runTask:886
>> >> > java.util.concurrent.ThreadPoolExecutor$Worker.run:908
>> >> > java.lang.Thread.run:619
>> >> > </ns:ExceptionText>
>> >> > </ns:Exception>
>> >> > <ns:Exception exceptionCode="JAVA_RootCause"/>
>> >> > </ns:ExceptionReport>
>> >> >
>> >> >
>> >> > the console output:
>> >> >
>> >> > 161203 [http-80-2] INFO org.n52.wps.server.request.Request - Handled
>> >> > Request successfully for: idw
>> >> > 1500453 [pool-1-thread-2] WARN
> org.n52.wps.server.request.InputHandler
>> >> > - No applicable parser found. Trying simpleGMLParser
>> >> > 1500453 [pool-1-thread-2] ERROR
>> >> > org.n52.wps.server.handler.RequestExecutor - Task execution failed:
>> >> > org.n52.wps.server.ExceptionReport: Error. No applicable parser found
>> >> > for null,application/x-zipped-shp,UTF-8
>> >> >
>> >> >
>> >> > My testrequest for idw:
>> >> >
>> >> > <wps:Execute service="WPS"
>> >> > version="1.0.0"
>> >> > xmlns:wps="http://www.opengis.net/wps/1.0.0"
>> >> > xmlns:ows="http://www.opengis.net/ows/1.1"
>> >> > xmlns:xlink="http://www.w3.org/1999/xlink"
>> >> > xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>> >> >
>> >
> xsi:schemaLocation="http://www.opengis.net/wps/1.0.0/wpsExecute_request.xsd">
>> >> >
>> >> > <ows:Identifier>idw</ows:Identifier>
>> >> > <wps:DataInputs>
>> >> > <wps:Input>
>> >> > <ows:Identifier>LAYER</ows:Identifier>
>> >> > <ows:Title>Die zu bearbeitenden Punkte</ows:Title>
>> >> > <wps:Reference mimeType="application/x-zipped-shp"
>> >> > xlink:href="http://localhost:80/data/test.zip"/>
>> >> > </wps:Input>
>> >> > <wps:Input>
>> >> > <ows:Identifier>FIELD</ows:Identifier>
>> >> > <wps:Data>
>> >> > <wps:LiteralData dataType="xs:int">0</wps:LiteralData>
>> >> > </wps:Data>
>> >> > </wps:Input>
>> >> > <wps:Input>
>> >> > <ows:Identifier>DIST</ows:Identifier>
>> >> > <wps:Data>
>> >> > <wps:LiteralData
>> >> > dataType="xs:double">16000</wps:LiteralData>
>> >> > </wps:Data>
>> >> > </wps:Input>
>> >> > <wps:Input>
>> >> > <ows:Identifier>POWER</ows:Identifier>
>> >> > <wps:Data>
>> >> > <wps:LiteralData dataType="xs:double">2.0</wps:LiteralData>
>> >> > </wps:Data>
>> >> > </wps:Input>
>> >> > <wps:Input>
>> >> > <ows:Identifier>GRID_EXTENT_X_MIN</ows:Identifier>
>> >> > <wps:Data>
>> >> > <wps:LiteralData
>> >> > dataType="xs:double">2557153.02</wps:LiteralData>
>> >> > </wps:Data>
>> >> > </wps:Input>
>> >> > <wps:Input>
>> >> > <ows:Identifier>GRID_EXTENT_X_MAX</ows:Identifier>
>> >> > <wps:Data>
>> >> > <wps:LiteralData
>> >> > dataType="xs:double">2616560.87</wps:LiteralData>
>> >> > </wps:Data>
>> >> > </wps:Input>
>> >> > <wps:Input>
>> >> > <ows:Identifier>GRID_EXTENT_Y_MIN</ows:Identifier>
>> >> > <wps:Data>
>> >> > <wps:LiteralData
>> >> > dataType="xs:double">5647888.89</wps:LiteralData>
>> >> > </wps:Data>
>> >> > </wps:Input>
>> >> > <wps:Input>
>> >> > <ows:Identifier>GRID_EXTENT_Y_MAX</ows:Identifier>
>> >> > <wps:Data>
>> >> > <wps:LiteralData
>> >> > dataType="xs:double">5692600.02</wps:LiteralData>
>> >> > </wps:Data>
>> >> > </wps:Input>
>> >> > <wps:Input>
>> >> > <ows:Identifier>GRID_EXTENT_CELLSIZE</ows:Identifier>
>> >> > <wps:Data>
>> >> > <wps:LiteralData dataType="xs:double">100</wps:LiteralData>
>> >> > </wps:Data>
>> >> > </wps:Input>
>> >> > </wps:DataInputs>
>> >> > <wps:ResponseForm>
>> >> > <wps:ResponseDocument>
>> >> > <wps:Output asReference="true">
>> >> > <ows:Identifier>RESULT</ows:Identifier>
>> >> > </wps:Output>
>> >> > </wps:ResponseDocument>
>> >> > </wps:ResponseForm>
>> >> > </wps:Execute>
>> >> >
>> >> >
>> >> >
>> >> >
>> >> >
>> >> >
>> >> >
>> >> >
>> >> > _______________________________________________
>> >> > Geoprocessingservices mailing list
>> >> > [hidden email]
>> >> > http://www2.52north.org/mailman/listinfo/geoprocessingservices
>> >>
>> >>
>> >> --
>> >> Bastian Schäffer
>> >> Institute for Geoinformatics (IfGI), University of Muenster, Germany
>> >> Weseler Str. 253, 48151 Muenster
>> >> Fon: +49 (0)251 - 83-30046 Fax: +49 (0)251 - 83-39763
>> >> email: [hidden email]
>> >> IfGI-site: http://ifgi.uni-muenster.de
>> >>
>> >>
>> >>
>> >
>> >
>> >
>> > _______________________________________________
>> > Geoprocessingservices mailing list
>> > [hidden email]
>> > http://www2.52north.org/mailman/listinfo/geoprocessingservices
>>
>>
>> --
>> Bastian Schäffer
>> Institute for Geoinformatics (IfGI), University of Muenster, Germany
>> Weseler Str. 253, 48151 Muenster
>> Fon: +49 (0)251 - 83-30046 Fax: +49 (0)251 - 83-39763
>> email: [hidden email]
>> IfGI-site: http://ifgi.uni-muenster.de
>>
>>
>>


--
Bastian Schäffer
Institute for Geoinformatics (IfGI), University of Muenster, Germany
Weseler Str. 253, 48151 Muenster
Fon: +49 (0)251 - 83-30046   Fax: +49 (0)251 - 83-39763
email: [hidden email]
IfGI-site: http://ifgi.uni-muenster.de



_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://www2.52north.org/mailman/listinfo/geoprocessingservices