52n-wps-client-lib License

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

52n-wps-client-lib License

Edi Karadumi
Hi list,

I would like to use the 52n-wps-client-lib module, but unfortunately its GNU GPL license is not compatible with the Apache 2.0 license of the software that I'm contributing. According to this section:

Software Licensing
Currently, most of our software is published under the GNU GPL V.2 license. Most future developments will use the Apache 2.0 license or similar non copy-left licenses.


future developments will be released under Apache 2.0 license. Will 52n-wps-client-lib module change its license to Apache? Is there any estimation on when it might change?

Kind Regards,
Edi Karadumi
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 52n-wps-client-lib License

Edi Karadumi
Hi again,

I am providing more info on the actual problem.

I am creating a gis-plugin for Apache Taverna. The plugin will add the support of geospatial web services to Taverna Workflows. I would like to use the 52n-web-client-lib to handle WPS services, but its license (GPL) it is not compatible with Apache Taverna license. Consequently, the plugin cannot be part of the official release.

You can track the discussion about this issue in the link below:

https://issues.apache.org/jira/browse/TAVERNA-1004

Kind Regards,
Edi Karadumi
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 52n-wps-client-lib License

BenjaminPross
Hello Edi,

Great that you want to use the wps-client-library. It really is just the examples that are using WPS modules under GPL 2. I will see what can be done about switching to Apache 2 and get back to you.

Cheers,

Benjamin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 52n-wps-client-lib License

BenjaminPross
In reply to this post by Edi Karadumi
Hi Edi,

with the new WPS release 3.5.0, the client-lib is now available under the Apache 2 license.

Cheers,

Benjamin
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: 52n-wps-client-lib License

Edi Karadumi
That's great. Thank you for your prompt feedback.

Thanks,
Edi Karadumi
Loading...