a problem about r.buffer2 request

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

a problem about r.buffer2 request

lvyou6412957
hi everyone:
  I set up the 52°North WPS with GRASS backend under Windows successfully,and when I execute r.buffer2 process with "http://geoprocessing.demo.52north.org:8080/xyz/basin_50K_nc.tif",It succeed.the request xml is
:r.xml.
   But when I download the basin_50k_nc.tif and put the tiff at " C:\apache-tomcat-7.0.54\webapps\ROOT\'' ,so I revise the "http://geoprocessing.demo.52north.org:8080/xyz/basin_50K_nc.tif"to"http://localhost:8080/basin_50K_nc.tif" It says "Error occured while receiving the complexReferenceURL: inputID: input | dataURL: http://192.168.3.253:8080/basin_50K_nc.tif" .what's wrong ? Is there someting requried to do for the input form?
Reply | Threaded
Open this post in threaded view
|

Re: a problem about r.buffer2 request

BenjaminPross
The input file does not seem to be accessible. Can you open the URL in a
browser?

Am 04.08.2014 04:55, schrieb lvyou6412957:

> hi everyone:
>    I set up the 52°North WPS with GRASS backend under Windows
> successfully,and when I execute r.buffer2 process with
> "http://geoprocessing.demo.52north.org:8080/xyz/basin_50K_nc.tif",It
> succeed.the request xml is
> : r.xml <http://geoprocessing.forum.52north.org/file/n4025737/r.xml>  .
>     But when I download the basin_50k_nc.tif and put the tiff at "
> C:\apache-tomcat-7.0.54\webapps\ROOT\'' ,so I revise the
> "http://geoprocessing.demo.52north.org:8080/xyz/basin_50K_nc.tif"to"http://localhost:8080/basin_50K_nc.tif"
> It says "Error occured while receiving the complexReferenceURL: inputID:
> input | dataURL: http://192.168.3.253:8080/basin_50K_nc.tif" .what's wrong ?
> Is there someting requried to do for the input form?
>
>
>
> --
> View this message in context: http://geoprocessing.forum.52north.org/a-problem-about-r-buffer2-request-tp4025737.html
> Sent from the 52° North - Geoprocessing Community Forum mailing list archive at Nabble.com.
> _______________________________________________
> Geoprocessingservices mailing list
> [hidden email]
> http://list.52north.org/mailman/listinfo/geoprocessingservices
> http://geoprocessing.forum.52north.org


--
Benjamin Proß
Software Engineer
52°North Geoprocessing Community

52°North Initiative for Geospatial Open Source Software GmbH
Martin-Luther-King-Weg 24
Fon: +49-(0)-251–396371-42
Fax: +49-(0)-251–396371-11
[hidden email]
http://52north.org/

General Managers: Dr. Albert Remke, Dr. Andreas Wytzisk
Local Court Muenster HRB 10849

_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/geoprocessingservices
http://geoprocessing.forum.52north.org
Reply | Threaded
Open this post in threaded view
|

Re: a problem about r.buffer2 request

lvyou6412957
Thanks for your reply. I have find the error,It's seems that the picture name contains a blank.
Reply | Threaded
Open this post in threaded view
|

Re: a problem about r.buffer2 request

amir_s
hi all,i can load url in browser but error not resolved;
thanks in advance!
Reply | Threaded
Open this post in threaded view
|

Re: a problem about r.buffer2 request

amir_s
In reply to this post by BenjaminPross
hi all,i can load url in browser but error not resolved;
thanks in advance!
Reply | Threaded
Open this post in threaded view
|

Re: a problem about r.buffer2 request

BenjaminPross
Hi,

In order to help you, we need more information. E.g. which version of the WPS do you use, did you add the GeoTools package, which URL did you try to access? The more information, the better.

Cheers,

Benjamin
Reply | Threaded
Open this post in threaded view
|

Re: a problem about r.buffer2 request

amir_s
This post was updated on .
hi
request and  responses are shown below:
thanks in advance!

/*********************request**********************/
<wps:Execute service="WPS" version="1.0.0"
        xmlns:wps="http://www.opengis.net/wps/1.0.0" 
        xmlns:ows="http://www.opengis.net/ows/1.1" 
        xmlns:xlink="http://www.w3.org/1999/xlink" 
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
        xsi:schemaLocation="http://www.opengis.net/wps/1.0.0 
        http://schemas.opengis.net/wps/1.0.0/wpsExecute_request.xsd"> 
        <ows:Identifier>union</ows:Identifier>                         
        <wps:DataInputs>               
        <wps:Input>               
    <ows:Identifier>LAYER1</ows:Identifier>               
    <wps:Reference mimeType="text/xml"
        xlink:href="https://sabac2gis.org:9443/geoserver/base/ows?service=WFS&amp;version=1.0.0&amp;request=GetFeature&amp;typeName=base:n52-test1"/>       
        </wps:Input>
        <wps:Input>               
    <ows:Identifier>LAYER2</ows:Identifier>
        <wps:Reference mimeType="text/xml"
        xlink:href="https://sabac2gis.org:9443/geoserver/base/ows?service=WFS&amp;version=1.0.0&amp;request=GetFeature&amp;typeName=base:n52-test"/>       
        </wps:Input>                   
        </wps:DataInputs>               
        <wps:ResponseForm>               
    <wps:ResponseDocument storeExecuteResponse="true"
        lineage="true" status="true">               
                           
        </wps:ResponseDocument>               
        </wps:ResponseForm>               
        </wps:Execute>
       
       
       
        /*********************response**********************/

        <wps:ExecuteResponse xmlns:wps="http://www.opengis.net/wps/1.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ows="http://www.opengis.net/ows/1.1" xsi:schemaLocation="http://www.opengis.net/wps/1.0.0 http://schemas.opengis.net/wps/1.0.0/wpsExecute_response.xsd" serviceInstance="https://sabac2gis.org:9444/wps/WebProcessingService?REQUEST=GetCapabilities&SERVICE=WPS" xml:lang="en-US" service="WPS" version="1.0.0" statusLocation="https://sabac2gis.org:9444/wps/RetrieveResultServlet?id=f5c76d73-6a34-4638-b23b-3cf54058bbd6">
<wps:Process wps:processVersion="1.0.0">
<ows:Identifier>union</ows:Identifier>
<ows:Title>Union</ows:Title>
</wps:Process>
<wps:Status creationTime="2017-07-22T12:49:01.599-07:00">
<wps:ProcessFailed>
<ows:ExceptionReport version="1.0.0">
<ows:Exception exceptionCode="NoApplicableCode">
<ows:ExceptionText>
org.n52.wps.server.ExceptionReport: Error occured while receiving the complexReferenceURL: inputID: LAYER1 | dataURL: https://sabac2gis.org:9443/geoserver/base/ows?service=WFS&version=1.0.0&request=GetFeature&typeName=base:n52-test1
</ows:ExceptionText>
</ows:Exception>
</ows:ExceptionReport>
</wps:ProcessFailed>
</wps:Status>
</wps:ExecuteResponse>

/***************response when copy and paste https://sabac2gis.org:9443/geoserver/base/ows?service=WFS&version=1.0.0&request=GetFeature&typeName=base:n52-test1 in browser*****/

<wfs:FeatureCollection xmlns="http://www.opengis.net/wfs" xmlns:wfs="http://www.opengis.net/wfs" xmlns:gml="http://www.opengis.net/gml" xmlns:base="http://www.saba.org/base" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.saba.org/base https://sabac2gis.org:9443/geoserver/base/wfs?service=WFS&version=1.0.0&request=DescribeFeatureType&typeName=base%3An52-test1 http://www.opengis.net/wfs https://sabac2gis.org:9443/geoserver/schemas/wfs/1.0.0/WFS-basic.xsd">
<gml:boundedBy>
<gml:null>unknown</gml:null>
</gml:boundedBy>
<gml:featureMember>
<base:n52-test1 fid="n52-test1.12">
<base:geom>
<gml:Polygon srsName="http://www.opengis.net/gml/srs/epsg.xml#4326">
<gml:outerBoundaryIs>
<gml:LinearRing>
<gml:coordinates xmlns:gml="http://www.opengis.net/gml" decimal="." cs="," ts=" ">
43.9453125,36.53612263 45.71411133,35.07496485 42.74780273,34.01624189 42.41821289,35.64836916 43.9453125,36.53612263
</gml:coordinates>
</gml:LinearRing>
</gml:outerBoundaryIs>
</gml:Polygon>
</base:geom>
</base:n52-test1>
</gml:featureMember>
</wfs:FeatureCollection>


Reply | Threaded
Open this post in threaded view
|

Re: a problem about r.buffer2 request

BenjaminPross
Its difficult to diagnose this issue... I cannot reach the WFS, so it seems to be protected in some way. I can only suggest to make sure, that the WFS is reachable from the WPS server.
Reply | Threaded
Open this post in threaded view
|

Re: a problem about r.buffer2 request

amir_s
hi.
good hint, i think so.
i will check it, but what is the fastest way to check connection between servers?

thanks very much.