importing maven projects - eclipse hangs at 12%

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

importing maven projects - eclipse hangs at 12%

wps noob
Hi all,

I'm just starting to play around with the wps and have already run into a problem that bars me from actually using the wps. I followed the explanations on how to set up the wps in eclipse to the letter (http://52north.org/communities/geoprocessing/wps/tutorials/WPSJEEHelios.html), until point 7.
Everything until there is fine and triple checked. But when I try to check the code out of the svn, it works just fine and saves the code on my disk until it reaches 12%. Then it just stops doing anything. Eclipse cannot be closed normally either, I have to go to the task manager to kill the process.

Is it possible that this doesn't work with Java 1.6? Because I sometimes (irritatingly not all the time) get this message after shutting down the process:
---------------------------
Eclipse
---------------------------
Java was started but returned exit code=1073807364
C:\Programme\Java\jdk1.6.0_22\bin\javaw.exe
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
-os win32
-ws win32
-arch x86
-showsplash
-launcher C:\Programme\eclipse\eclipse.exe
-name Eclipse
--launcher.library C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.100.v20110502\eclipse_1406.dll
-startup C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
--launcher.overrideVmargs
-exitdata c1c_40
-product org.eclipse.epp.package.jee.product
-vm C:\Programme\Java\jdk1.6.0_22\bin\javaw.exe
-vmargs
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar

Or is there something else I missed? Is this a know issues?

Sorry for the probably noobish question. Some hints would be appreciated.

Yours truly

_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/geoprocessingservices
http://geoprocessing.forum.52north.org
Reply | Threaded
Open this post in threaded view
|

Re: importing maven projects - eclipse hangs at 12%

Bastian Schäffer-2
Hi,

this problem has been reported a couple of times. It is not reproducible
on every machine and I do not know an answer for it.

For me it looks like a problem with the eclipse SVN client. It is just a
checkout from an SVN server.

One option would be to try another SVN client and then import it as mvn
project once checked out.

In cc is also out IT-Support.
@IT-Support: Please have a look at the SVN server logs.

Regards,
Bastian

Am 01.07.2011 13:46, schrieb wps noob:

> Hi all,
>
> I'm just starting to play around with the wps and have already run into
> a problem that bars me from actually using the wps. I followed the
> explanations on how to set up the wps in eclipse to the letter
> (http://52north.org/communities/geoprocessing/wps/tutorials/WPSJEEHelios.html),
> until point 7.
> Everything until there is fine and triple checked. But when I try to
> check the code out of the svn, it works just fine and saves the code on
> my disk until it reaches 12%. Then it just stops doing anything. Eclipse
> cannot be closed normally either, I have to go to the task manager to
> kill the process.
>
> Is it possible that this doesn't work with Java 1.6? Because I sometimes
> (irritatingly not all the time) get this message after shutting down the
> process:
> ---------------------------
> Eclipse
> ---------------------------
> Java was started but returned exit code=1073807364
> C:\Programme\Java\jdk1.6.0_22\bin\javaw.exe
> -Dosgi.requiredJavaVersion=1.5
> -Xms40m
> -Xmx512m
> -XX:MaxPermSize=256m
> -jar
> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
> -os win32
> -ws win32
> -arch x86
> -showsplash
> -launcher C:\Programme\eclipse\eclipse.exe
> -name Eclipse
> --launcher.library
> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.100.v20110502\eclipse_1406.dll
> -startup
> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
> --launcher.overrideVmargs
> -exitdata c1c_40
> -product org.eclipse.epp.package.jee.product
> -vm C:\Programme\Java\jdk1.6.0_22\bin\javaw.exe
> -vmargs
> -Dosgi.requiredJavaVersion=1.5
> -Xms40m
> -Xmx512m
> -XX:MaxPermSize=256m
> -jar
> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>
>
> Or is there something else I missed? Is this a know issues?
>
> Sorry for the probably noobish question. Some hints would be appreciated.
>
> Yours truly
>
>
>
> _______________________________________________
> Geoprocessingservices mailing list
> [hidden email]
> http://list.52north.org/mailman/listinfo/geoprocessingservices
> http://geoprocessing.forum.52north.org


--
Bastian Schäffer
52° North Initiative for Geospatial Open Source Software GmbH
Martin-Luther-King-Weg 24
Fon: +49-(0)-251–396371-41  Fax: +49-(0)-251–396371-11
email: [hidden email]
52North-site: http://www.52North.org
General Managers: Dr. Albert Remke, Dr. Andreas Wytzisk
Local Court Muenster HRB 10849


_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/geoprocessingservices
http://geoprocessing.forum.52north.org
Reply | Threaded
Open this post in threaded view
|

Re: importing maven projects - eclipse hangs at 12%

wps noob
In reply to this post by wps noob
Thanks for the answer and the forward to the IT-Support.

As mentioned, the code actually ends up on my disk (don't know if complete tho), but if I try to import it from disk (Eclipse -> File -> Import -> Maven -> Existing Maven Projects) it hangs at 12% too.

I will try and check out the code with tortoise. I'll report back on the results.

Yours truly
_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/geoprocessingservices
http://geoprocessing.forum.52north.org
Reply | Threaded
Open this post in threaded view
|

Re: importing maven projects - eclipse hangs at 12%

Bastian Schäffer-2
Then it seems to be a problem with the Eclipse MVN plugin (which
sometime a bit "special").

One option is to import it as plain java project and then enable it as a
mvn project once imported.

Note to myself: We have to add this issue to the FAQ once a workaround
is found.

Am 01.07.2011 14:10, schrieb wps noob:

> Thanks for the answer and the forward to the IT-Support.
>
> As mentioned, the code actually ends up on my disk (don't know if
> complete tho), but if I try to import it from disk (Eclipse -> File ->
> Import -> Maven -> Existing Maven Projects) it hangs at 12% too.
>
> I will try and check out the code with tortoise. I'll report back on the
> results.
>
> Yours truly
>
>
>
> _______________________________________________
> Geoprocessingservices mailing list
> [hidden email]
> http://list.52north.org/mailman/listinfo/geoprocessingservices
> http://geoprocessing.forum.52north.org


--
Bastian Schäffer
52° North Initiative for Geospatial Open Source Software GmbH
Martin-Luther-King-Weg 24
Fon: +49-(0)-251–396371-41  Fax: +49-(0)-251–396371-11
email: [hidden email]
52North-site: http://www.52North.org
General Managers: Dr. Albert Remke, Dr. Andreas Wytzisk
Local Court Muenster HRB 10849


_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/geoprocessingservices
http://geoprocessing.forum.52north.org
Reply | Threaded
Open this post in threaded view
|

Re: importing maven projects - eclipse hangs at 12%

52North
Administrator
In reply to this post by Bastian Schäffer-2
Hi Bastian,
before taking a look in the SVN log, please give some more details on
the time and folder, which were requested from the SVN.

Kind regards,
Eike

Am 01.07.2011 13:59, schrieb Bastian Schäffer:

> Hi,
>
> this problem has been reported a couple of times. It is not
> reproducible on every machine and I do not know an answer for it.
>
> For me it looks like a problem with the eclipse SVN client. It is just
> a checkout from an SVN server.
>
> One option would be to try another SVN client and then import it as
> mvn project once checked out.
>
> In cc is also out IT-Support.
> @IT-Support: Please have a look at the SVN server logs.
>
> Regards,
> Bastian
>
> Am 01.07.2011 13:46, schrieb wps noob:
>> Hi all,
>>
>> I'm just starting to play around with the wps and have already run into
>> a problem that bars me from actually using the wps. I followed the
>> explanations on how to set up the wps in eclipse to the letter
>> (http://52north.org/communities/geoprocessing/wps/tutorials/WPSJEEHelios.html),
>>
>> until point 7.
>> Everything until there is fine and triple checked. But when I try to
>> check the code out of the svn, it works just fine and saves the code on
>> my disk until it reaches 12%. Then it just stops doing anything. Eclipse
>> cannot be closed normally either, I have to go to the task manager to
>> kill the process.
>>
>> Is it possible that this doesn't work with Java 1.6? Because I sometimes
>> (irritatingly not all the time) get this message after shutting down the
>> process:
>> ---------------------------
>> Eclipse
>> ---------------------------
>> Java was started but returned exit code=1073807364
>> C:\Programme\Java\jdk1.6.0_22\bin\javaw.exe
>> -Dosgi.requiredJavaVersion=1.5
>> -Xms40m
>> -Xmx512m
>> -XX:MaxPermSize=256m
>> -jar
>> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>>
>> -os win32
>> -ws win32
>> -arch x86
>> -showsplash
>> -launcher C:\Programme\eclipse\eclipse.exe
>> -name Eclipse
>> --launcher.library
>> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.100.v20110502\eclipse_1406.dll
>>
>> -startup
>> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>>
>> --launcher.overrideVmargs
>> -exitdata c1c_40
>> -product org.eclipse.epp.package.jee.product
>> -vm C:\Programme\Java\jdk1.6.0_22\bin\javaw.exe
>> -vmargs
>> -Dosgi.requiredJavaVersion=1.5
>> -Xms40m
>> -Xmx512m
>> -XX:MaxPermSize=256m
>> -jar
>> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>>
>>
>>
>> Or is there something else I missed? Is this a know issues?
>>
>> Sorry for the probably noobish question. Some hints would be
>> appreciated.
>>
>> Yours truly
>>
>>
>>
>> _______________________________________________
>> Geoprocessingservices mailing list
>> [hidden email]
>> http://list.52north.org/mailman/listinfo/geoprocessingservices
>> http://geoprocessing.forum.52north.org
>
>
_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/geoprocessingservices
http://geoprocessing.forum.52north.org
Reply | Threaded
Open this post in threaded view
|

Re: importing maven projects - eclipse hangs at 12%

Bastian Schäffer-2
Hi Eike,

here is the requested information:

WPS trunk

around 01.07.2011 13:46



Am 05.07.2011 08:43, schrieb IT-Support:

> Hi Bastian,
> before taking a look in the SVN log, please give some more details on
> the time and folder, which were requested from the SVN.
>
> Kind regards,
> Eike
>
> Am 01.07.2011 13:59, schrieb Bastian Schäffer:
>> Hi,
>>
>> this problem has been reported a couple of times. It is not
>> reproducible on every machine and I do not know an answer for it.
>>
>> For me it looks like a problem with the eclipse SVN client. It is just
>> a checkout from an SVN server.
>>
>> One option would be to try another SVN client and then import it as
>> mvn project once checked out.
>>
>> In cc is also out IT-Support.
>> @IT-Support: Please have a look at the SVN server logs.
>>
>> Regards,
>> Bastian
>>
>> Am 01.07.2011 13:46, schrieb wps noob:
>>> Hi all,
>>>
>>> I'm just starting to play around with the wps and have already run into
>>> a problem that bars me from actually using the wps. I followed the
>>> explanations on how to set up the wps in eclipse to the letter
>>> (http://52north.org/communities/geoprocessing/wps/tutorials/WPSJEEHelios.html),
>>>
>>> until point 7.
>>> Everything until there is fine and triple checked. But when I try to
>>> check the code out of the svn, it works just fine and saves the code on
>>> my disk until it reaches 12%. Then it just stops doing anything. Eclipse
>>> cannot be closed normally either, I have to go to the task manager to
>>> kill the process.
>>>
>>> Is it possible that this doesn't work with Java 1.6? Because I sometimes
>>> (irritatingly not all the time) get this message after shutting down the
>>> process:
>>> ---------------------------
>>> Eclipse
>>> ---------------------------
>>> Java was started but returned exit code=1073807364
>>> C:\Programme\Java\jdk1.6.0_22\bin\javaw.exe
>>> -Dosgi.requiredJavaVersion=1.5
>>> -Xms40m
>>> -Xmx512m
>>> -XX:MaxPermSize=256m
>>> -jar
>>> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>>>
>>> -os win32
>>> -ws win32
>>> -arch x86
>>> -showsplash
>>> -launcher C:\Programme\eclipse\eclipse.exe
>>> -name Eclipse
>>> --launcher.library
>>> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.100.v20110502\eclipse_1406.dll
>>>
>>> -startup
>>> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>>>
>>> --launcher.overrideVmargs
>>> -exitdata c1c_40
>>> -product org.eclipse.epp.package.jee.product
>>> -vm C:\Programme\Java\jdk1.6.0_22\bin\javaw.exe
>>> -vmargs
>>> -Dosgi.requiredJavaVersion=1.5
>>> -Xms40m
>>> -Xmx512m
>>> -XX:MaxPermSize=256m
>>> -jar
>>> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>>>
>>>
>>>
>>> Or is there something else I missed? Is this a know issues?
>>>
>>> Sorry for the probably noobish question. Some hints would be
>>> appreciated.
>>>
>>> Yours truly
>>>
>>>
>>>
>>> _______________________________________________
>>> Geoprocessingservices mailing list
>>> [hidden email]
>>> http://list.52north.org/mailman/listinfo/geoprocessingservices
>>> http://geoprocessing.forum.52north.org
>>


--
Bastian Schäffer
52° North Initiative for Geospatial Open Source Software GmbH
Martin-Luther-King-Weg 24
Fon: +49-(0)-251–396371-41  Fax: +49-(0)-251–396371-11
email: [hidden email]
52North-site: http://www.52North.org
General Managers: Dr. Albert Remke, Dr. Andreas Wytzisk
Local Court Muenster HRB 10849



_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/geoprocessingservices
http://geoprocessing.forum.52north.org
Reply | Threaded
Open this post in threaded view
|

Re: importing maven projects - eclipse hangs at 12%

52North
Administrator
Hi bastian,
during this time are typical problems like:

[Fri Jul 01 13:47:58 2011] [error] [client XX.XX.XX.XX] Could not fetch
resource information.  [301, #0], referer:
http://52north.org/resources/source-repositories/
[Fri Jul 01 13:47:58 2011] [error] [client XX.XX.XX.XX] (2)No such file
or directory: Requests for a collection must have a trailing slash on
the URI.  [301, #0], referer:
http://52north.org/resources/source-repositories/

Is the problem still there? Could you provide the IP range.

Kind regards,
Eike



Am 05.07.2011 09:10, schrieb Bastian Schäffer:

> Hi Eike,
>
> here is the requested information:
>
> WPS trunk
>
> around 01.07.2011 13:46
>
>
>
> Am 05.07.2011 08:43, schrieb IT-Support:
>> Hi Bastian,
>> before taking a look in the SVN log, please give some more details on
>> the time and folder, which were requested from the SVN.
>>
>> Kind regards,
>> Eike
>>
>> Am 01.07.2011 13:59, schrieb Bastian Schäffer:
>>> Hi,
>>>
>>> this problem has been reported a couple of times. It is not
>>> reproducible on every machine and I do not know an answer for it.
>>>
>>> For me it looks like a problem with the eclipse SVN client. It is just
>>> a checkout from an SVN server.
>>>
>>> One option would be to try another SVN client and then import it as
>>> mvn project once checked out.
>>>
>>> In cc is also out IT-Support.
>>> @IT-Support: Please have a look at the SVN server logs.
>>>
>>> Regards,
>>> Bastian
>>>
>>> Am 01.07.2011 13:46, schrieb wps noob:
>>>> Hi all,
>>>>
>>>> I'm just starting to play around with the wps and have already run
>>>> into
>>>> a problem that bars me from actually using the wps. I followed the
>>>> explanations on how to set up the wps in eclipse to the letter
>>>> (http://52north.org/communities/geoprocessing/wps/tutorials/WPSJEEHelios.html),
>>>>
>>>>
>>>> until point 7.
>>>> Everything until there is fine and triple checked. But when I try to
>>>> check the code out of the svn, it works just fine and saves the
>>>> code on
>>>> my disk until it reaches 12%. Then it just stops doing anything.
>>>> Eclipse
>>>> cannot be closed normally either, I have to go to the task manager to
>>>> kill the process.
>>>>
>>>> Is it possible that this doesn't work with Java 1.6? Because I
>>>> sometimes
>>>> (irritatingly not all the time) get this message after shutting
>>>> down the
>>>> process:
>>>> ---------------------------
>>>> Eclipse
>>>> ---------------------------
>>>> Java was started but returned exit code=1073807364
>>>> C:\Programme\Java\jdk1.6.0_22\bin\javaw.exe
>>>> -Dosgi.requiredJavaVersion=1.5
>>>> -Xms40m
>>>> -Xmx512m
>>>> -XX:MaxPermSize=256m
>>>> -jar
>>>> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>>>>
>>>>
>>>> -os win32
>>>> -ws win32
>>>> -arch x86
>>>> -showsplash
>>>> -launcher C:\Programme\eclipse\eclipse.exe
>>>> -name Eclipse
>>>> --launcher.library
>>>> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.100.v20110502\eclipse_1406.dll
>>>>
>>>>
>>>> -startup
>>>> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>>>>
>>>>
>>>> --launcher.overrideVmargs
>>>> -exitdata c1c_40
>>>> -product org.eclipse.epp.package.jee.product
>>>> -vm C:\Programme\Java\jdk1.6.0_22\bin\javaw.exe
>>>> -vmargs
>>>> -Dosgi.requiredJavaVersion=1.5
>>>> -Xms40m
>>>> -Xmx512m
>>>> -XX:MaxPermSize=256m
>>>> -jar
>>>> C:\Programme\eclipse\\plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
>>>>
>>>>
>>>>
>>>>
>>>> Or is there something else I missed? Is this a know issues?
>>>>
>>>> Sorry for the probably noobish question. Some hints would be
>>>> appreciated.
>>>>
>>>> Yours truly
>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> Geoprocessingservices mailing list
>>>> [hidden email]
>>>> http://list.52north.org/mailman/listinfo/geoprocessingservices
>>>> http://geoprocessing.forum.52north.org
>>>
>
>
_______________________________________________
Geoprocessingservices mailing list
[hidden email]
http://list.52north.org/mailman/listinfo/geoprocessingservices
http://geoprocessing.forum.52north.org